BidSlammer Forum My BidSlammer Dashboard >>

BidSlammer Forums >> Help & Troubleshooting


lost credits

Posted: Dec 07 2009 01:37 PM

i am aware i have not used bidslammer for a long while.





i paid $20 for 25 snipes in 16/12/2004 - i'm pretty sure i have not used all these snipes, but when i relogged today into my account it says i have zero credit.





could you investigate, and if due to system upgrade etc in the meantime i have lost credit i would appreciate some token as I'd like to reuse the service. i received an email saying all payments never expire, so it would be good to know...





many thanks,





matt


Posted Dec 07 2009 01:37 pm by Gu***st

Matt,





I see a payment from five years ago. There is no credit left in the account though. Payments after 2006 do not expire. What happened was the FREE portion expired after 2 years, those were the terms at the time. However we don't do this any more, and we don't charge dimes for misses, and we tripled the service offering, so everyone is much happier.

Thank you for taking the time to write in, if you have any other questions, please be sure to let us know.





Cheers,





Jay


BidSlammer Customer Care
 


Posted Dec 07 2009 01:55 pm by Gu***st

thanks jay. i'm sure i actually paid for credits too, but am aware i got a free portion too.





thanks for getting back to me, and i will be sure to update, as i get a lot out of the service when i use it actively. just been off ebay for a while :) cheers, matt


Posted Dec 07 2009 03:17 pm by Gu***st

Hello,





No problem, here's a penny tshirt for you.





https://bidslammer.com/user/tshirt.penny.php?mattbrighton


Posted Dec 07 2009 03:24 pm by Gu***st

Reply to this discussion


Sorry, only BidSlammer customers are allowed to post in the forum.   Join now

 



Join Now! Start winning items today.

© BidSlammer 2001-2021. All Rights Reserved.

Home | Help | FAQ | Screenshots | Blog | Community | Contact Us
Collectors | BidSlammer API | Terms | Privacy | Site Map