BidSlammer Forum My BidSlammer Dashboard >>

BidSlammer Forums >> Help & Troubleshooting


balance shows zero

Posted: Apr 12 2010 09:10 AM

when i first joined bidslammer i had put $25.00 towards my account and i used the site a few times. this is when snipes were .10 cents i used it maybe a half dozen times or so maybe little more but i do know i never used up the whole amount. you site has since gone thru some reconstruction and my account was never lost but somehow by balance is zero. i will provide any information or bank statements you require to prove that somehow my balance of 20 plus dollars was confiscated in your refreshing your web site. please give this some attention and email me what course of action needs to be taken to resolve this issue. i know i havent used this service in over 2 years and looking to use it again plus its money that is owed to me. thank you for your help. you can also call me if you need to at [edited]. jeffrey c george


Posted Apr 12 2010 09:10 am by Gu***st

Hi,





First I checked your account for any illegal activity and all is ok there...





What happened was the FREE portion expired after 2 years, those were the terms at the time. However we don't do this any more, and we don't charge dimes for misses, and we tripled the service offering, so everyone is much happier.

Thank you for taking the time to write in, if you have any other questions, please be sure to let us know.





Cheers,





Jay


BidSlammer Customer Care
 


Posted Apr 12 2010 11:24 am by Gu***st

Reply to this discussion


Sorry, only BidSlammer customers are allowed to post in the forum.   Join now

 



Join Now! Start winning items today.

© BidSlammer 2001-2020. All Rights Reserved.

Home | Help | FAQ | Screenshots | Blog | Contact Us
Collectors | BidSlammer API | Terms | Privacy | Site Map