BidSlammer Forum My BidSlammer Dashboard >>

BidSlammer Forums >> Help & Troubleshooting


I have not received a refund!

Posted: Mar 21 2011 12:38 AM

I missed a snipe on item #220744428325 but my home page says I won the auction. I have submitted two tickets for this. The first one, #N1DTAH66Q3, got deleted from your system without a response. When I submitted the second ticket, #PLHX6VDJPH, Jayslam responded that I would receive a credit for the missing funds. That was on March 6th. It has now been two weeks, and I have not received a credit. Would you please look into this and credit my account immediately? I feel I have been patient, and have received poor service on this matter. Thank you.


Posted Mar 21 2011 12:38 am by Gu***st

Maria,





Just a quick note to let you know we are closing this ticket, I did confirm we issued a credit.





On the day you wrote we posted a public response to say we are issuing double credits and I confirmed.





Thanks for your continued trust and interest in BidSlammer!

Thank you for taking the time to write in, if you have any other questions, please be sure to let us know.





Cheers,





Jay


BidSlammer Customer Care
 


Posted Apr 09 2011 03:02 pm by Gu***st

Reply to this discussion


Sorry, only BidSlammer customers are allowed to post in the forum.   Join now

 



Join Now! Start winning items today.

© BidSlammer 2001-2021. All Rights Reserved.

Home | Help | FAQ | Screenshots | Blog | Community | Contact Us
Collectors | BidSlammer API | Terms | Privacy | Site Map